※ 블로그내 모든 자료는 불특정시기에 수정되므로 링크스크랩을 권장합니다.

 ※ 과제등에 인용시, 출처 명시 바랍니다.

posted by MTG 2017.01.05 20:55


mono.android.DesignerException: Android version not supported by the designer

at mono.android.DesignerSession.initialize(DesignerSession.java:112)

at mono.android.Project.createSession(Project.java:401)

at mono.android.Project.processMessage(Project.java:432)

at mono.android.MessageListener.executeMessage(MessageListener.java:88)

at mono.android.MessageListener$Runner.run(MessageListener.java:45)

at java.lang.Thread.run(Thread.java:745)

A valid android SDK could not be found…an existing SDK with platform-tools and at least one platform needs to be registered with the IDE


자마린에서 *.axml의 레이아웃 디자인이 안 열린다.






해법


* 기존 SDK경로

> D:\dev_lib\android_sdk_windows


1) SDK 재설치


2) API레벨 지정

프로퍼티와 AndroidManifest.xml를 세팅합니다.






기타. 참조


"Connection to the layout renderer failed" in XS 5.7 and XamarinVS 3.9 — Xamarin Forums

xamarin - A valid android SDK could not be found...an existing SDK with platform-tools and at least one platform needs to be registered with the IDE - Stack Overflow





기타. 변경이력


일자

변경이력

2017-01-05

 초안

신고

댓글을 달아 주세요